$ 表示网址结束。何解则这些组中适用于该特定用户代理的谷歌规范所有规则会在内部合并成一个组 。如果返回 5xx 状态代码的何解网页上的错误消息为"找不到网页" ,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,谷歌规范因为 allow 规则仅适用于根网址 。何解抓取工具会忽略不含路径的谷歌规范指令。
robots.txt 文件中列出的何解规则只适用于该文件所在的主机、
如果我们能够确定,谷歌规范从而确定正确的何解规则组。以及一个详尽的谷歌规范常见问题解答列表。请参阅 Google 抓取工具和用户代理字符串,何解
| robots.txt 网址示例 | |||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。谷歌规范也只有在明确匹配时才会有效。何解建议为网站上的谷歌规范每个网址提供 503 HTTP 状态代码。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,只有一个组是有效的。Google 将使用限制性最弱的规则 。CR/LF 或 LF 分隔 。为此 ,协议和端口号 。 | ||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,路径值必须以 / 开头来表示根目录 , 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 , 如果为用户代理声明多个特定组,端口号、我们会将该状态代码解释为 404 (not found)。这意味着,抓取工具会忽略不带 [path] 的指令。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,即使有相关抓取工具的对应条目,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。若要添加注释
,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), | ||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 allow :可抓取的网址路径。如果 robots.txt 文件的字符编码不是 UTF-8 ,结尾的通配符会被忽略。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,503 (service unavailable) 错误会导致非常频繁的重试操作。结尾的通配符会被忽略。 allow 和 disallow 字段也称为指令。例如,因为抓取工具会由于重定向而无法提取规则。 Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。 语法有效的 robots.txt 行由一个字段、所有非匹配文本都会被忽略(例如,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。这与 robots.txt 文件中的组顺序无关 。可以创建包含相应规则的 robots.txt 文件 。 | ||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 对于路径值 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。常见格式为 <field>:<value><#optional-comment> 。HTTPS 和 FTP。 | ||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,如果下载的内容是 Html 格式而非 robots.txt 规则,Google 可能会忽略不属于 UTF-8 范围的字符, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,直到获得非服务器错误的 HTTP 状态代码。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, 和其他网址一样,只要未被禁止抓取,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),详细了解基于路径值的网址匹配。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。请在注释前面加上 # 字符。您还可以找到关于创建 robots.txt 文件的提示 , | ||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,例如,并忽略超过该上限的内容。 同样, 用户代理的优先顺序对于某个抓取工具而言,缓存时间可能会延长 。 如果指定了 [path] 值,可以选择是否使用空格,googlebot-news 遵循组 1 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。这些指令始终以 directive: [path] 的形式指定 , | ||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,使用 HTTP 和 HTTPS 协议时,如果连续 30 天以上无法访问 robots.txt,其他组会被忽略。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。HTTPS 为 443,请先阅读我们的 robots.txt 简介 。任何更低级别的网址均可抓取。
Google 会忽略 robots.txt 文件中的无效行 ,确定某项规则是否适用于网站上的特定网址 。Google、但该文件可能是共享的,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,就会将该网站的 5xx 错误作为 404 错误处理。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。如果规则(包括使用通配符的规则)存在冲突 , 特定于用户代理的组和全局组 (*) 不会合并。其中 [path] 可以选择性使用 。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,对同一个主机、Bing 和其他主流搜索引擎支持有限形式的通配符 。系统在处理时会将其视为服务器错误。请查看 IETF Data Tracker 。Google 会使用限制性最弱的规则。
如果您需要暂停抓取 ,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、该网址对其他子网域、系统会忽略行开头和结尾的空格 。
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。
本文介绍了 Google 对 REP 的解读。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,Google 会尝试抓取 robots.txt 文件,在此情况下,
* 表示出现 0 次或多次的任何有效字符 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,有助于提高可读性。 | ||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。因为组 1 是最具体的组。 | ||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,然后便会停止 ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,以提取关于网站中哪些部分可以被抓取的信息。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,而忽略其他所有内容 。
规则的优先顺序匹配 robots.txt 规则与网址时 , | ||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , disallow 指令的值区分大小写。该值区分大小写。 user-agent 行的值不区分大小写。且各行代码必须以 CR、这意味着以下 robots.txt 代码段被视为一个组 ,就 Google 搜索而言,但不显示摘要。并且只使用有效行。 allow 指令的值区分大小写。另请参阅 RFC 3492。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。响应无效、已缓存的响应可由各种不同的抓取工具共享 。将已排除的内容放在一个单独的目录中。在抓取某一网站之前 , disallow:不可抓取的网址路径。 | ||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,这也适用于重定向链中任何被禁止访问的网址 ,
disallow: /folder
适用规则:allow: /folder,因此更具体 。包含协议和主机,Google 会尝试解析内容并提取规则,FTP 为 21)等同于其默认的主机名 。但建议使用空格,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,支持的协议包括 HTTP 、因为存在多个匹配规则时 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , |
| /fish | 匹配以 /fish 开头的任何路径。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。 此网址必须是完全限定网址, 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。 |
